tendermint-rs's Light Client Verifier allows malicious validators to spoof votes from other validatorsGHSA-6jrf-4jv4-r9mw
Fix: informalsystems/tendermint-rs@1aabcfeGHSA-6jrf-4jv4-r9mw is a security vulnerability in tendermint-light-client-verifier. A fix is available for tendermint-light-client-verifier — see the affected versions and patch details below.
Real-World Exposure
tendermint-light-client-verifierReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Name: ISA-2025-003: Malicious validator can spoof votes from other validators Component: tendermint-rs Criticality: High (Catastrophic Impact; Rare Likelihood per ACMv1.2) Affected versions: <= v0.40.2 Affected users: Everyone
Description
tendermint-rs contains a critical vulnerability in its light client implementation due to insecure handling of corrupted validator sets. Because it doesn't check that the validator address is correctly derived from the validator's public key when counting votes, it is possible to spoof votes from other validators. The result is being able to construct the malicious block and cheat the light client. The light client will accept such a block, seemingly signed by 2/3+ majority.
Patches
The new tendermint-rs release v0.40.3 fixes this issue.
Unreleased code in the main branch is patched as well.
Workarounds
There are no known workarounds for this issue.
Timeline
- March 12, 2025, 13:41pm PST: Issue reported
- March 12, 2025, 03:00am PST: Core team completes validation of issue
This issue was reported by Felix Wilhelm from Asymmetric Research.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | tendermint-light-client-verifier | all versions | 0.40.3cargo update -p tendermint-light-client-verifier --precise 0.40.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for tendermint-light-client-verifier, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update tendermint-light-client-verifier to 0.40.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6jrf-4jv4-r9mw is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-6jrf-4jv4-r9mw in your dependencies?
Find it across crates.io, including transitive dependencies.