Sandbox Breakout in realms-shimGHSA-6jg8-7333-554w
CRITICALGHSA-6jg8-7333-554w is a critical-severity (CVSS 9.8) remote code execution vulnerability in realms-shim. A fix is available for realms-shim — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, a proxy for how much of the ecosystem is exposed.
realms-shimnpmsesnpmDescription
Versions of realms-shim prior to 1.2.0 are vulnerable to a Sandbox Breakout. Reflect.construct can be used on the sandboxed Function constructor to reach the prototypes of the primal Realm, which may allow an attacker to escape the sandbox and execute arbitrary code.
Recommendation
Upgrade to version 1.2.0 or later.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | realms-shim | all versions | 1.2.0npm install realms-shim@1.2.0 |
| 📦npm | ses | all versions | 0.6.3npm install ses@0.6.3 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for realms-shim, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update realms-shim to 1.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6jg8-7333-554w is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-6jg8-7333-554w in your dependencies?
Find it across npm, including transitive dependencies.