Weave GitOps Terraform Controller Information Disclosure VulnerabilityGHSA-6hvv-j432-23cv
HIGHFix: weaveworks/tf-controller@28282bcGHSA-6hvv-j432-23cv is a high-severity (CVSS 8.5) Information Exposure vulnerability in github.com/weaveworks/tf-controller. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for github.com/weaveworks/tf-controller — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-6hvv-j432-23cv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/weaveworks/tf-controller🐹github.com/weaveworks/tf-controllerReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
A vulnerability has been identified in Weave GitOps Terraform Controller which could allow an authenticated remote attacker to view sensitive information. This vulnerability stems from Weave GitOps Terraform Runners (tf-runner), where sensitive data is inadvertently printed - potentially revealing sensitive user data in their pod logs. In particular, functions tfexec.ShowPlan, tfexec.ShowPlanRaw, and tfexec.Output are implicated when the tfexec object set its Stdout and Stderr to be os.Stdout and os.Stderr.
An unauthorized remote attacker could exploit this vulnerability by accessing these prints of sensitive information, which may contain configurations or tokens that could be used to gain unauthorized control or access to resources managed by the Terraform controller.
A successful exploit could allow the attacker to utilize this sensitive data, potentially leading to unauthorized access or control of the system.
Patches
This vulnerability has been addressed in Weave GitOps Terraform Controller versions v0.14.4 and v0.15.0-rc.5. Users are urged to upgrade to one of these versions to mitigate the vulnerability.
The patches for this vulnerability are found in:
- this commit: 9708fda28ccd0466cb0a8fd409854ab4d92f7dca
- this commit: 6323b355bd7f5d2ce85d0244fe0883af3881df4e
- this commit: 28282bc644054e157c3b9a3d38f1f9551ce09074
- and this commit: 98a0688036e9dbcf43fa84960d9a1ef3e09a69cf
Workarounds
As a temporary measure until the patch can be applied, users can add the environment variable DISABLE_TF_LOGS to the tf-runners via the runner pod template of the Terraform Custom Resource. This will prevent the logging of sensitive information and mitigate the risk of this vulnerability.
References
- The first issue: https://github.com/weaveworks/tf-controller/issues/637
- The second issue: https://github.com/weaveworks/tf-controller/issues/649
For More Information
If you have any further questions or comments about this advisory:
Open an issue in the Weave GitOps Terraform Controller repository Email us at [email protected]
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/weaveworks/tf-controller | all versions | 0.14.4go get github.com/weaveworks/tf-controller@v0.14.4 |
| 🐹Go | github.com/weaveworks/tf-controller | ≥ 0.15.0-rc.1&&< 0.15.0-rc.5 | 0.15.0-rc.5go get github.com/weaveworks/tf-controller@v0.15.0-rc.5 |
Affected Products
gitops terraform controllerweaveResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/weaveworks/tf-controller, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/weaveworks/tf-controller to 0.14.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6hvv-j432-23cv is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-6hvv-j432-23cv in your dependencies?
Find it across Go, including transitive dependencies.