NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

Server crashes on invalid Cloud Function or Cloud Job nameGHSA-6hh7-46r2-vf29

CRITICALFix: parse-community/parse-server@5ae6d6a

GHSA-6hh7-46r2-vf29 is a critical-severity (CVSS 9) CWE-74 vulnerability in parse-server. A fix is available for parse-server — see the affected versions and patch details below.

Also known asBIT-parse-2024-29027CVE-2024-29027
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-6hh7-46r2-vf29.

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs68th percentile — riskier than 68% of all scored CVEsHighest risk
0.69%1.26%1.83%2.40%1.9%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

62other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
parse-servernpm
65Kdownloads / week

Description

Impact

Calling an invalid Parse Server Cloud Function name or Cloud Job name crashes server and may allow for code injection.

Patches

Added string sanitation for Cloud Function name and Cloud Job name.

Workarounds

Sanitize the Cloud Function name and Cloud Job name before it reaches Parse Server.

References

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
📦npmparse-serverall versions6.5.5npm install parse-server@6.5.5
📦npmparse-server≥ 7.0.0-alpha.1&&< 7.0.0-alpha.297.0.0-alpha.29npm install parse-server@7.0.0-alpha.29

Affected Products

1 product · 29 configurations
Application
parse-serverparseplatform
< 6.5.5
1 version
7.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for parse-server, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update parse-server to 6.5.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6hh7-46r2-vf29 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Impact Calling an invalid Parse Server Cloud Function name or Cloud Job name crashes server and may allow for code injection. ### Patches Added string sanitation for Cloud Function name and Cloud Job name. ### Workarounds Sanitize the Cloud Function name and Cloud Job name before it reaches Parse Server. ### References - https://github.com/parse-community/parse-server/security/advisories/GHSA-6hh7-46r2-vf29 - https://github.com/parse-community/parse-server/releases/tag/7.0.0-alpha.29 (Fix for Parse Server 7 alpha) - https://github.com/parse-community/parse-server/releases/tag/6.5.5
O3 Security · Impact-Aware SCA

Is GHSA-6hh7-46r2-vf29 in your dependencies?

Find it across npm, including transitive dependencies.

Server crashes on invalid Cloud Function or Cloud Job…