NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀 crates.io
Not in CISA KEV

`openssl` `X509Extension::new` and `X509Extension::new_nid` null pointer dereferenceGHSA-6hcf-g6gr-hhcr

Fix: sfackler/rust-openssl#1854

GHSA-6hcf-g6gr-hhcr is a security vulnerability in openssl. A fix is available for openssl — see the affected versions and patch details below.

Also known asRUSTSEC-2023-0024
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 8, 2023 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
🦀openssl

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

These functions would crash when the context argument was None with certain extension types.

Thanks to David Benjamin (Google) for reporting this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.ioopenssl≥ 0.9.7&&< 0.10.480.10.48cargo update -p openssl --precise 0.10.48

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openssl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openssl to 0.10.48 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6hcf-g6gr-hhcr is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

These functions would crash when the context argument was None with certain extension types. Thanks to David Benjamin (Google) for reporting this issue.
O3 Security · Impact-Aware SCA

Is GHSA-6hcf-g6gr-hhcr in your dependencies?

Find it across crates.io, including transitive dependencies.

`openssl` `X509Extension::new` and `X509Extension::new_…