NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Electron vulnerable to URL spoofing via PDFiumGHSA-6h98-cf9g-vmg2

MEDIUMFix: electron/electron#10008

GHSA-6h98-cf9g-vmg2 is a medium-severity (CVSS 4.3) vulnerability in electron. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for electron — see the affected versions and patch details below.

Also known asCVE-2017-1000424
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.99%1.48%0.3%1.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
electronnpm
12.1Mdownloads / week

Description

Github Electron version 1.6.4 - 1.6.11 and 1.7.0 - 1.7.5 is vulnerable to a URL Spoofing problem when opening PDFs in PDFium resulting loading arbitrary PDFs that a hacker can control.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmelectron≥ 1.7.0&&< 1.7.61.7.6npm install electron@1.7.6

Affected Products

1 product · 2 configurations
Application
electronatom
≥ 1.7.0 && ≤ 1.7.5
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for electron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update electron to 1.7.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6h98-cf9g-vmg2 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Electron version 1.7.0 - 1.7.5 is vulnerable to a URL Spoofing problem when opening PDFs in PDFium resulting loading arbitrary PDFs that a hacker can control.
O3 Security · Impact-Aware SCA

Is GHSA-6h98-cf9g-vmg2 in your dependencies?

Find it across npm, including transitive dependencies.

Electron vulnerable to URL spoofing via PDFium