NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍 PyPI
Not in CISA KEV

autogluon.multimodal vulnerable to unsafe YAML deserializationGHSA-6h2x-4gjf-jc5w

Fix: awslabs/autogluon#1987

GHSA-6h2x-4gjf-jc5w is a remote code execution vulnerability in autogluon-multimodal. A fix is available for autogluon-multimodal — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 2, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐍autogluon-multimodal🐍autogluon-multimodal

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Impact

A potential unsafe deserialization issue exists within the autogluon.multimodal module, where YAML files are loaded via yaml.load() instead of yaml.safe_load(). The deserialization of untrusted data may allow an unprivileged third party to cause remote code execution, denial of service, and impact to both confidentiality and integrity.

Impacted versions: >=0.4.0;<0.4.3, >=0.5.0;<0.5.2.

Patches

The patches are included in autogluon.multimodal==0.4.3, autogluon.multimodal==0.5.2 and Deep Learning Containers 0.4.3 and 0.5.2.

Workarounds

Do not load data which originated from an untrusted source, or that could have been tampered with. Only load data you trust.

References

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIautogluon-multimodal≥ 0.4.0&&< 0.4.30.4.3pip install --upgrade 'autogluon-multimodal==0.4.3'
🐍PyPIautogluon-multimodal≥ 0.5.0&&< 0.5.20.5.2pip install --upgrade 'autogluon-multimodal==0.5.2'

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for autogluon-multimodal, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update autogluon-multimodal to 0.4.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6h2x-4gjf-jc5w is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

### Impact A potential unsafe deserialization issue exists within the `autogluon.multimodal` module, where YAML files are loaded via `yaml.load()` instead of `yaml.safe_load()`. The deserialization of untrusted data may allow an unprivileged third party to cause remote code execution, denial of service, and impact to both confidentiality and integrity. Impacted versions: `>=0.4.0;<0.4.3`, `>=0.5.0;<0.5.2`. ### Patches The patches are included in `autogluon.multimodal==0.4.3`, `autogluon.multimodal==0.5.2` and Deep Learning Containers `0.4.3` and `0.5.2`. ### Workarounds Do not load data wh
O3 Security · Impact-Aware SCA

Is GHSA-6h2x-4gjf-jc5w in your dependencies?

Find it across PyPI, including transitive dependencies.

autogluon.multimodal vulnerable to unsafe YAML…