NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

TYPO3 Allows Privilege Escalation to System MaintainerGHSA-6frx-j292-c844

HIGHFix: TYPO3-CMS/core@a659cc8

GHSA-6frx-j292-c844 is a high-severity (CVSS 7.2) CWE-283 vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

Also known asCVE-2025-47940
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-6frx-j292-c844.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs40th percentile — riskier than 40% of all scored CVEsHighest risk
0.00%0.32%0.64%0.96%0.3%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core🐘typo3/cms-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

TYPO3 is an open source, PHP based web content management system. Starting in version 10.0.0 and prior to versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, and 13.4.12 LTS, administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. Users should update to TYPO3 version 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, or 13.4.12 LTS to fix the problem.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 10.4.0&&< 10.4.5010.4.50composer require typo3/cms-core:^10.4.50
🐘Packagisttypo3/cms-core≥ 11.0.0&&< 11.5.4411.5.44composer require typo3/cms-core:^11.5.44
🐘Packagisttypo3/cms-core≥ 12.0.0&&< 12.4.3112.4.31composer require typo3/cms-core:^12.4.31
🐘Packagisttypo3/cms-core≥ 13.0.0&&< 13.4.1213.4.12composer require typo3/cms-core:^13.4.12

Affected Products

1 product · 4 configurations
Application
typo3typo3
≥ 13.0.0 && < 13.4.12
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 10.4.50 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6frx-j292-c844 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Problem Administrator-level backend users without system maintainer privileges can escalate their privileges and gain system maintainer access. Exploiting this vulnerability requires a valid administrator account. ### Solution Update to TYPO3 versions 10.4.50 ELTS, 11.5.44 ELTS, 12.4.31 LTS, 13.4.12 LTS that fix the problem described. ### Credits Thanks to Alexander Künzl for reporting this issue, and to TYPO3 core & security team member Oliver Hader for fixing it.
O3 Security · Impact-Aware SCA

Is GHSA-6frx-j292-c844 in your dependencies?

Find it across Packagist, including transitive dependencies.

TYPO3 Allows Privilege Escalation to System Maintainer