NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Moodle CSRF risk in analytics management of modelsGHSA-68x5-4jg5-gjgg

HIGHFix: moodle/moodle@498a766

GHSA-68x5-4jg5-gjgg is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asBIT-moodle-2024-34008CVE-2024-34008
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-68x5-4jg5-gjgg.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs34th percentile — riskier than 34% of all scored CVEsHighest risk
0.00%0.30%0.60%0.90%0.4%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.3.0&&< 4.3.44.3.4composer require moodle/moodle:^4.3.4
🐘Packagistmoodle/moodle≥ 4.2.0&&< 4.2.74.2.7composer require moodle/moodle:^4.2.7
🐘Packagistmoodle/moodleall versions4.1.10composer require moodle/moodle:^4.1.10

Affected Products

1 product · 3 configurations
Application
moodlemoodle
≥ 4.2 && < 4.2.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-68x5-4jg5-gjgg is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Actions in the admin management of analytics models did not include the necessary token to prevent a CSRF risk.
O3 Security · Impact-Aware SCA

Is GHSA-68x5-4jg5-gjgg in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle CSRF risk in analytics management of models