Shopware Broken ACL on Document retrieval to access other customers documentsGHSA-68wv-g3fw-pq7q
MEDIUMGHSA-68wv-g3fw-pq7q is a medium-severity (CVSS 4) vulnerability in shopware/core. A fix is available for shopware/core — see the affected versions and patch details below.
Real-World Exposure
shopware/core🐘shopware/platform🐘shopware/core🐘shopware/platform🐘shopware/core🐘shopware/platformReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Impact
It's possible to guess the deepLinkCode of an Document to open documents of other customers
Patches
Update to Shopware 6.6.10.3 or 6.5.8.17
Workarounds
For older versions of 6.4, corresponding security measures are also available via a plugin. For the full range of functions, we recommend updating to the latest Shopware version.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shopware/core | ≥ 6.6.0.0&&< 6.6.10.3 | 6.6.10.3composer require shopware/core:^6.6.10.3 |
| 🐘Packagist | shopware/platform | ≥ 6.6.0.0&&< 6.6.10.3 | 6.6.10.3composer require shopware/platform:^6.6.10.3 |
| 🐘Packagist | shopware/core | ≥ 6.7.0.0-rc1&&< 6.7.0.0-rc2 | 6.7.0.0-rc2composer require shopware/core:^6.7.0.0-rc2 |
| 🐘Packagist | shopware/platform | ≥ 6.7.0.0-rc1&&< 6.7.0.0-rc2 | 6.7.0.0-rc2composer require shopware/platform:^6.7.0.0-rc2 |
| 🐘Packagist | shopware/core | all versions | 6.5.8.17composer require shopware/core:^6.5.8.17 |
| 🐘Packagist | shopware/platform | all versions | 6.5.8.17composer require shopware/platform:^6.5.8.17 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shopware/core to 6.6.10.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-68wv-g3fw-pq7q is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-68wv-g3fw-pq7q in your dependencies?
Find it across Packagist, including transitive dependencies.