NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Directus vulnerable to SSRF Loopback IP filter bypassGHSA-68g8-c275-xf2m

MEDIUMFix: directus/directus@4aace0b

GHSA-68g8-c275-xf2m is a medium-severity (CVSS 5) CWE-284 vulnerability in directus. A fix is available for directus — see the affected versions and patch details below.

Also known asCVE-2024-46990
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-68g8-c275-xf2m.

EPSS Exploitation Probability

via FIRST.org ↗
0.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs41th percentile — riskier than 41% of all scored CVEsHighest risk
0.00%0.32%0.64%0.97%0.2%0.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

12other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
directusnpm
36Kdownloads / week
@directus/apinpm
25Kdownloads / week

Description

Directus is a real-time API and App dashboard for managing SQL database content. When relying on blocking access to localhost using the default 0.0.0.0 filter a user may bypass this block by using other registered loopback devices (like 127.0.0.2 - 127.127.127.127). This issue has been addressed in release versions 10.13.3 and 11.1.0. Users are advised to upgrade. Users unable to upgrade may block this bypass by manually adding the 127.0.0.0/8 CIDR range which will block access to any 127.X.X.X ip instead of just 127.0.0.1.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
📦npmdirectusall versions10.13.3npm install directus@10.13.3
📦npmdirectus≥ 11.0.0&&< 11.1.011.1.0npm install directus@11.1.0
📦npm@directus/apiall versions21.0.0npm install @directus/api@21.0.0
📦npm@directus/api≥ 22.0.0&&< 22.1.122.1.1npm install @directus/api@22.1.1

Affected Products

1 product · 2 configurations
Application
directusmonospace
≥ 11.0.0 && < 11.1.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for directus, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update directus to 10.13.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-68g8-c275-xf2m is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

### Impact If you're relying on blocking access to localhost using the default `0.0.0.0` filter this can be bypassed using other registered loopback devices (like `127.0.0.2` - `127.127.127.127`) ### Workaround You can block this bypass by manually adding the `127.0.0.0/8` CIDR range which will block access to any `127.X.X.X` ip instead of just `127.0.0.1`.
O3 Security · Impact-Aware SCA

Is GHSA-68g8-c275-xf2m in your dependencies?

Find it across npm, including transitive dependencies.

Directus vulnerable to SSRF Loopback IP filter bypass