Potential leakage of Sentry auth tokens by React Native SDK with Expo pluginGHSA-68c2-4mpx-qh95
Fix: getsentry/sentry-react-native@9148964GHSA-68c2-4mpx-qh95 is a security vulnerability in @sentry/react-native. A fix is available for @sentry/react-native — see the affected versions and patch details below.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
@sentry/react-nativenpmDescription
Impact
SDK versions between and including 5.16.0 and 5.19.0 allowed Sentry auth tokens to be set in the optional authToken configuration parameter, for debugging purposes. Doing so would result in the auth token being built into the application bundle, and therefore the auth token could be potentially exposed in case the application bundle is subsequently published.
You may ignore this notification if you are not using authToken configuration parameter in your React Native SDK configuration or did not publish apps using this way of configuring the authToken.
If you had set the authToken in the plugin config previously, and built and published an app with that config, you should rotate your token.
Patches
The behavior that allowed setting an authToken parameter was fixed in SDK version 5.19.1 where, if this parameter was set, you will see a warning and the authToken would be removed before bundling the application.
Workarounds
- Remove
authTokenfrom the plugin configuration. - If you had set the
authTokenin the plugin config previously, and built and published an app with that config, you should rotate your token.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | @sentry/react-native | ≥ 5.16.0&&< 5.19.1 | 5.19.1npm install @sentry/react-native@5.19.1 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @sentry/react-native, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update @sentry/react-native to 5.19.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-68c2-4mpx-qh95 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-68c2-4mpx-qh95 in your dependencies?
Find it across npm, including transitive dependencies.