NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

n8n: Wrong OAuth Scope on Evaluation Test Runs EndpointsGHSA-664h-gpgq-h6xx

MEDIUM

GHSA-664h-gpgq-h6xx is a medium-severity (CVSS 5.4) CWE-863 vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.

Also known asCVE-2026-56775
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-664h-gpgq-h6xx.

EPSS Exploitation Probability

via FIRST.org ↗
0.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs23th percentile — riskier than 23% of all scored CVEsHighest risk
0.00%0.27%0.53%0.80%0.2%0.3%0.3%0.3%0.3%Aug 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

36other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
n8nnpm
123Kdownloads / week

Description

Impact

Three mutating endpoints in the evaluation test runs controller authorized state-changing actions using workflow:read instead of the action-appropriate workflow:execute scope. An authenticated user with project:viewer role on a project could start new evaluation test runs, cancel in-flight runs, and delete run records for workflows they only had read access to.

This issue only affects instances with Advanced Permissions (Enterprise/Cloud) where projects and viewer roles are in use.

Patches

The issue has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should upgrade to one of these versions or later to remediate the vulnerability.

Workarounds

If upgrading is not immediately possible, administrators should consider the following temporary mitigations:

  • Restrict project membership to fully trusted users only.
  • Avoid granting viewer access to projects containing sensitive workflows.

These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
📦npmn8nall versions1.123.55npm install n8n@1.123.55
📦npmn8n≥ 2.26.0&&< 2.26.22.26.2npm install n8n@2.26.2
📦npmn8n≥ 2.0.0-rc.0&&< 2.25.72.25.7npm install n8n@2.25.7

Affected Products

1 product · 3 configurations
Application
n8nn8n
≥ 2.26.0 && < 2.26.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update n8n to 1.123.55 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-664h-gpgq-h6xx is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

## Impact Three mutating endpoints in the evaluation test runs controller authorized state-changing actions using `workflow:read` instead of the action-appropriate `workflow:execute` scope. An authenticated user with `project:viewer` role on a project could start new evaluation test runs, cancel in-flight runs, and delete run records for workflows they only had read access to. This issue only affects instances with Advanced Permissions (Enterprise/Cloud) where projects and viewer roles are in use. ## Patches The issue has been fixed in n8n versions 1.123.55, 2.25.7, and 2.26.2. Users should
O3 Security · Impact-Aware SCA

Is GHSA-664h-gpgq-h6xx in your dependencies?

Find it across npm, including transitive dependencies.

n8n: Wrong OAuth Scope on Evaluation Test Runs…