NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Denial of Service in rgb2hexGHSA-65p8-3hm4-h9h8

MEDIUM

GHSA-65p8-3hm4-h9h8 is a medium-severity (CVSS 6.5) vulnerability in rgb2hex. A fix is available for rgb2hex — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Aug 17, 2021 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

48other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
rgb2hexnpm
2.7Mdownloads / week

Description

All versions of rgb2hex are vulnerable to Regular Expression Denial of Service (ReDoS) when an attacker can pass in a specially crafted invalid color value.

Recommendation

Update to version 0.1.6 or later.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmrgb2hexall versions0.1.6npm install rgb2hex@0.1.6

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for rgb2hex, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update rgb2hex to 0.1.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-65p8-3hm4-h9h8 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

All versions of `rgb2hex` are vulnerable to Regular Expression Denial of Service (ReDoS) when an attacker can pass in a specially crafted invalid color value. ## Recommendation Update to version 0.1.6 or later.
O3 Security · Impact-Aware SCA

Is GHSA-65p8-3hm4-h9h8 in your dependencies?

Find it across npm, including transitive dependencies.

Denial of Service in rgb2hex (Medium 6.5)