NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
LOW severity

AWS SDK for JavaScript v3 adopted defense in depth enhancement for region parameter valueGHSA-6475-r3vj-m8vf

LOW

GHSA-6475-r3vj-m8vf is a low-severity (CVSS 3.7) vulnerability in @smithy/config-resolver. A fix is available for @smithy/config-resolver — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

113other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
@smithy/config-resolvernpm
48.4Mdownloads / week

Description

CVSSv3.1 Rating: 3.7 (LOW)

Summary

This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value.

A defense-in-depth enhancement has been implemented in the AWS SDK for JavaScript v3 (versions 3.723.0 and later). This enhancement validates that a region used to construct an endpoint URL is a valid host label. The change was released on November 15, 2025. This advisory is informational to help customers understand their responsibilities regarding configuration security.

Impact Customer applications could be configured to improperly route AWS API calls to non-existent or non-AWS hosts. While the SDK was functioning as designed, additional safeguards have been added to support secure customer implementations.

Impacted versions: @smithy/config-resolver <4.4.0

Patches

On November 15, 2025, an enhancement was made to the AWS SDK for JavaScript v3 (versions 3.723.0 and later) release, which validates the formatting of a region, providing additional safeguards. A feature enhancement was implemented in @smithy/config-resolver v4.4.0. This enhancement provides additional configuration validation safeguards but does not address a security vulnerability.

Workarounds No workarounds are needed, but as always you should ensure that your application is following security best practices:

  • Implement proper input validation in your application code
  • Update to the latest AWS SDK for Javascript v3 release on a regular basis
  • Follow AWS security best practices [1] for SDK configuration

Resources Contact AWS Security via the vulnerability reporting page or email [email protected].

Acknowledgement AWS Security thanks Guy Arazi for bringing these customer security considerations to our attention through the coordinated disclosure process.

[1] https://docs.aws.amazon.com/sdk-for-javascript/v3/developer-guide/security.html

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npm@smithy/config-resolverall versions4.4.0npm install @smithy/config-resolver@4.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for @smithy/config-resolver, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update @smithy/config-resolver to 4.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-6475-r3vj-m8vf is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

CVSSv3.1 Rating: 3.7 (LOW) Summary This notification is related to the use of specific values for the region input field when calling AWS services. An actor with access to the environment in which the SDK is used could set the region input field to an invalid value. A defense-in-depth enhancement has been implemented in the AWS SDK for JavaScript v3 (versions 3.723.0 and later). This enhancement validates that a region used to construct an endpoint URL is a valid host label. The change was released on November 15, 2025. This advisory is informational to help customers understand their respo
O3 Security · Impact-Aware SCA

Is GHSA-6475-r3vj-m8vf in your dependencies?

Find it across npm, including transitive dependencies.

AWS SDK for JavaScript v3 adopted defense in depth…