AWS SageMaker Training Toolkit logs CodeArtifact Authorization tokenGHSA-635v-pc42-fr74
MEDIUMFix: aws/sagemaker-training-toolkit@d8e56c9GHSA-635v-pc42-fr74 is a medium-severity (CVSS 4.2) vulnerability in sagemaker-training. A fix is available for sagemaker-training — see the affected versions and patch details below.
Real-World Exposure
sagemaker-trainingReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
Description
For SageMaker Training Toolkit[1] versions 4.7.4; 4.7.3; 4.7.2; 4.7.1; 4.7.0, the authorization tokens for CodeArtifact (temporary token with an expiration of 12 hours) were logged in the log files when the CodeArtifact capability was enabled. If customers push these log files to their CloudWatch Log streams, anyone having access to cloudwatch logs within their AWS account, may be abe to see the authorization token. If the token is not expired, they may use the authorization token to publish or consume CodeArtifact package versions.
This issue was addressed in version 4.8.0. We recommend users upgrade to version 4.8.0 or higher.
Please note that users can add SageMaker Training Toolkit to any Docker container[2] used for SageMaker training[3]. It also comes pre-packaged with the prebuilt SageMaker Docker image[4] for SageMaker training.
Patches
This issue has been addressed in version 4.8.0 and higher.
Workarounds
N/A
References
N/A
If you have any questions or comments about this advisory we ask that you contact AWS/Amazon Security via our vulnerability reporting page[5] or directly via email to [email protected]. Please do not create a public GitHub issue.
[1] https://github.com/aws/sagemaker-training-toolkit [2] https://www.docker.com/resources/what-container/ [3] https://aws.amazon.com/sagemaker/train/ [4] https://docs.aws.amazon.com/sagemaker/latest/dg/pre-built-containers-frameworks-deep-learning.html [5] Vulnerability reporting page: https://aws.amazon.com/security/vulnerability-reporting
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | sagemaker-training | ≥ 4.7.0&&< 4.8.0 | 4.8.0pip install --upgrade 'sagemaker-training==4.8.0' |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sagemaker-training, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sagemaker-training to 4.8.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-635v-pc42-fr74 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-635v-pc42-fr74 in your dependencies?
Find it across PyPI, including transitive dependencies.