NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

Karate has vulnerable dependency on json-smart package (CVE-2023-1370)GHSA-5x5q-8cgm-2hjq

HIGH

GHSA-5x5q-8cgm-2hjq is a high-severity (CVSS 7.5) vulnerability in com.intuit.karate:karate-core. A fix is available for com.intuit.karate:karate-core — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Jan 7, 2025 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected
☕com.intuit.karate:karate-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Summary

The CVE image

How to fix it

Very simple, just upgrade json-path package to 2.8.0 (from 2.7.0) inside karate-core pom.xml ;)

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.intuit.karate:karate-core≥ 1.3.1&&< 1.4.01.4.0com.intuit.karate:karate-core:1.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.intuit.karate:karate-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.intuit.karate:karate-core to 1.4.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5x5q-8cgm-2hjq is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Summary The CVE ![image](https://user-images.githubusercontent.com/2663049/229081854-1155c041-56fa-48ca-a7ff-f2f085b845fd.png) ### How to fix it Very simple, just upgrade json-path package to 2.8.0 (from 2.7.0) inside karate-core pom.xml ;)
O3 Security · Impact-Aware SCA

Is GHSA-5x5q-8cgm-2hjq in your dependencies?

Find it across Maven, including transitive dependencies.

Karate has vulnerable dependency on json-smart package…