NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹 Go
Not in CISA KEV

Etcd pkg Insecure ciphers are allowed by defaultGHSA-5x4g-q5rc-36jp

GHSA-5x4g-q5rc-36jp is a security vulnerability in go.etcd.io/etcd/client/pkg/v3. A fix is available for go.etcd.io/etcd/client/pkg/v3 — see the affected versions and patch details below.

Also known asGO-2024-2527
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Sep 10, 2026 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐹go.etcd.io/etcd/client/pkg/v3🐹go.etcd.io/etcd/client/pkg/v3

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

Vulnerability type

Cryptography

Detail

The TLS ciphers list supported by etcd contains insecure cipher suites. Users can configure the desired ciphers using the “--cipher-suites” flag, and a default list of secure cipher suites is used if empty.

Workarounds

By default, no action is required. If users want to specify cipher suites using the '--cipher-suites' flag, they should try not to specify insecure cipher suites. Please refer to the security documentation.

References

Find out more on this vulnerability in the security audit report

For more information

If you have any questions or comments about this advisory:

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogo.etcd.io/etcd/client/pkg/v3≥ 3.4.0-rc.0&&< 3.4.103.4.10go get go.etcd.io/etcd/client/pkg/v3@v3.4.10
🐹Gogo.etcd.io/etcd/client/pkg/v3all versions3.3.23go get go.etcd.io/etcd/client/pkg/v3@v3.3.23

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for go.etcd.io/etcd/client/pkg/v3, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update go.etcd.io/etcd/client/pkg/v3 to 3.4.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5x4g-q5rc-36jp is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

### Vulnerability type Cryptography ### Detail The TLS ciphers list supported by etcd contains insecure cipher suites. Users can configure the desired ciphers using the “--cipher-suites” flag, and a default list of secure cipher suites is used if empty. ### Workarounds By default, no action is required. If users want to specify cipher suites using the '--cipher-suites' flag, they should try not to specify insecure cipher suites. Please refer to the [security documentation](https://etcd.io/docs/v3.4/op-guide/security/). ### References Find out more on this vulnerability in the [security audi
O3 Security · Impact-Aware SCA

Is GHSA-5x4g-q5rc-36jp in your dependencies?

Find it across Go, including transitive dependencies.

Etcd pkg Insecure ciphers are allowed by default