NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

Apache Camel camel-hessian component vulnerable to Java object deserializationGHSA-5whj-523x-6j68

CRITICAL

GHSA-5whj-523x-6j68 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in org.apache.camel:camel-hessian. A fix is available for org.apache.camel:camel-hessian — see the affected versions and patch details below.

Also known asCVE-2017-12633
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
2.28%4.30%6.31%8.33%3.4%7.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.apache.camel:camel-hessian☕org.apache.camel:camel-hessian

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

The camel-hessian component in Apache Camel 2.x before 2.19.4 and 2.20.x before 2.20.1 is vulnerable to Java object de-serialisation vulnerability. De-serializing untrusted data can lead to security flaws.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.camel:camel-hessian≥ 2.0&&< 2.19.42.19.4org.apache.camel:camel-hessian:2.19.4
☕Mavenorg.apache.camel:camel-hessian≥ 2.20.0&&< 2.20.12.20.1org.apache.camel:camel-hessian:2.20.1

Affected Products

1 product · 2 configurations
Application
camelapache
≥ 2.20.0 && < 2.20.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.camel:camel-hessian, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.camel:camel-hessian to 2.19.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5whj-523x-6j68 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Frequently Asked Questions

The camel-hessian component in Apache Camel 2.x before 2.19.4 and 2.20.x before 2.20.1 is vulnerable to Java object de-serialisation vulnerability. De-serializing untrusted data can lead to security flaws.
O3 Security · Impact-Aware SCA

Is GHSA-5whj-523x-6j68 in your dependencies?

Find it across Maven, including transitive dependencies.

Apache Camel camel-hessian component vulnerable to…