Moodle Exposure of Sensitive Information to an Unauthorized ActorGHSA-5w4h-xrr5-7273
MEDIUMGHSA-5w4h-xrr5-7273 is a medium-severity (CVSS 5.3) Information Exposure vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in moodle before versions 3.5.1, 3.4.4, 3.3.7, 3.1.13. It was possible for the core_course_get_categories web service to return hidden categories, which should be omitted when fetching course categories.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.1&&< 3.1.13 | 3.1.13composer require moodle/moodle:^3.1.13 |
| 🐘Packagist | moodle/moodle | ≥ 3.3&&< 3.3.7 | 3.3.7composer require moodle/moodle:^3.3.7 |
| 🐘Packagist | moodle/moodle | ≥ 3.4&&< 3.4.4 | 3.4.4composer require moodle/moodle:^3.4.4 |
| 🐘Packagist | moodle/moodle | ≥ 3.5&&< 3.5.1 | 3.5.1composer require moodle/moodle:^3.5.1 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.1.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5w4h-xrr5-7273 is resolved across your whole dependency graph.
Workarounds
Assume what was exposed is already known: rotate any credential, token or key that the affected component could return, restrict the endpoint to callers that genuinely need it, and strip sensitive fields from responses and error output at the boundary rather than relying on the client not to read them.
Frequently Asked Questions
Is GHSA-5w4h-xrr5-7273 in your dependencies?
Find it across Packagist, including transitive dependencies.