Magento 2 Community Edition RCE VulnerabilityGHSA-5v5p-x8c2-mqxp
HIGHGHSA-5v5p-x8c2-mqxp is a high-severity (CVSS 8.8) remote code execution vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A remote code execution vulnerability exists in Magento 2.1 prior to 2.1.19, Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3. An authenticated user with privileges to create products can craft custom layout update and use import product functionality to enable remote code execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.1.0&&< 2.1.19 | 2.1.19composer require magento/community-edition:^2.1.19 |
| 🐘Packagist | magento/community-edition | ≥ 2.2.0&&< 2.2.10 | 2.2.10composer require magento/community-edition:^2.2.10 |
| 🐘Packagist | magento/community-edition | ≥ 2.3.0&&< 2.3.3 | 2.3.3composer require magento/community-edition:^2.3.3 |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.1.19 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5v5p-x8c2-mqxp is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-5v5p-x8c2-mqxp in your dependencies?
Find it across Packagist, including transitive dependencies.