NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💧
💧 Hex
Not in CISA KEV
HIGH severity

Arbitrary Code Execution in Cookie SerializationGHSA-5v4m-c73v-c7gq

HIGH

GHSA-5v4m-c73v-c7gq is a high-severity (CVSS 8.1) Deserialization of Untrusted Data vulnerability in plug. A fix is available for plug — see the affected versions and patch details below.

Also known asCVE-2017-1000053
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 7, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs80th percentile — riskier than 80% of all scored CVEsHighest risk
0.57%1.19%1.81%2.43%1.1%1.9%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
💧plug💧plug💧plug💧plug

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex packages — download data is not available via public APIs for these ecosystems.

Description

The default serialization used by Plug session may result in code execution in certain situations. Keep in mind, however, the session cookie is signed and this attack can only be exploited if the attacker has access to your secret key as well as your signing/encryption salts. We recommend users to change their secret key base and salts if they suspect they have been leaked, regardless of this vulnerability.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
💧Hexplugall versions1.0.4mix deps.update plug
💧Hexplug≥ 1.1.0&&< 1.1.71.1.7mix deps.update plug
💧Hexplug≥ 1.2.0&&< 1.2.31.2.3mix deps.update plug
💧Hexplug≥ 1.3.0&&< 1.3.21.3.2mix deps.update plug

Affected Products

1 product · 4 configurations
Application
plugplug_project
≥ 1.3.0 && < 1.3.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plug, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update plug to 1.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5v4m-c73v-c7gq is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

The default serialization used by Plug session may result in code execution in certain situations. Keep in mind, however, the session cookie is signed and this attack can only be exploited if the attacker has access to your secret key as well as your signing/encryption salts. We recommend users to change their secret key base and salts if they suspect they have been leaked, regardless of this vulnerability.
O3 Security · Impact-Aware SCA

Is GHSA-5v4m-c73v-c7gq in your dependencies?

Find it across Hex, including transitive dependencies.

Arbitrary Code Execution in Cookie Serialization (High 8.1)