NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Clamscan vulnerable to command injectionGHSA-5v25-xr56-phph

HIGHFix: kylefarris/clamscan#45

GHSA-5v25-xr56-phph is a high-severity (CVSS 8.1) OS Command Injection vulnerability in clamscan. A fix is available for clamscan — see the affected versions and patch details below.

Also known asCVE-2020-7613SNYK-JS-CLAMSCAN-564113
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
1.30%1.74%2.18%2.62%1.8%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

40other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
clamscannpm
535Kdownloads / week

Description

clamscan through 1.2.0 is vulnerable to Command Injection. It is possible to inject arbitrary commands as part of the _is_clamav_binary function located within Index.js. It should be noted that this vulnerability requires a pre-requisite that a folder should be created with the same command that will be chained to execute. This lowers the risk of this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmclamscanall versions1.3.0npm install clamscan@1.3.0

Affected Products

1 product · 1 configurations
Application
clamscanclamscan_project
≤ 1.2.0
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for clamscan, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update clamscan to 1.3.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5v25-xr56-phph is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

clamscan through 1.2.0 is vulnerable to Command Injection. It is possible to inject arbitrary commands as part of the `_is_clamav_binary` function located within `Index.js`. It should be noted that this vulnerability requires a pre-requisite that a folder should be created with the same command that will be chained to execute. This lowers the risk of this issue.
O3 Security · Impact-Aware SCA

Is GHSA-5v25-xr56-phph in your dependencies?

Find it across npm, including transitive dependencies.

Clamscan vulnerable to command injection (High 8.1)