NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

RCE vulnerability in Pimcore/Mail & Dynamic Text LayoutGHSA-5qxq-vgmm-q39m

CRITICALFix: pimcore/pimcore#13347

GHSA-5qxq-vgmm-q39m is a critical-severity (CVSS 9.8) Code Injection vulnerability in pimcore/pimcore. A fix is available for pimcore/pimcore — see the affected versions and patch details below.

Also known asCVE-2022-39365
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.00%0.96%1.93%2.89%0.2%2.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘pimcore/pimcore

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Impact

The user controlled twig templates rendering in Pimcore/Mail & ClassDefinition\Layout\Text is vulnerable to server-side template Injection RCE.

Patches

Update to version 10.5.9 or apply this patch manually https://github.com/pimcore/pimcore/pull/13347.patch

Workarounds

Apply https://github.com/pimcore/pimcore/pull/13347.patch manually.

References

Credits: @nth347 from Viettel Cyber Security

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistpimcore/pimcoreall versions10.5.9composer require pimcore/pimcore:^10.5.9

Affected Products

1 product · 1 configurations
Application
pimcorepimcore
< 10.5.9
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for pimcore/pimcore, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update pimcore/pimcore to 10.5.9 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5qxq-vgmm-q39m is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

### Impact The user controlled twig templates rendering in `Pimcore/Mail` & `ClassDefinition\Layout\Text` is vulnerable to server-side template Injection RCE. ### Patches Update to version 10.5.9 or apply this patch manually https://github.com/pimcore/pimcore/pull/13347.patch ### Workarounds Apply https://github.com/pimcore/pimcore/pull/13347.patch manually. ### References Credits: @nth347 from Viettel Cyber Security
O3 Security · Impact-Aware SCA

Is GHSA-5qxq-vgmm-q39m in your dependencies?

Find it across Packagist, including transitive dependencies.

RCE vulnerability in Pimcore/Mail & Dynamic Text Layout