OpenClaw: BlueBubbles beta plugin webhook auth hardening (remove passwordless fallback)GHSA-5mx2-2mgw-x8rm
MEDIUMFix: openclaw/openclaw@283029bGHSA-5mx2-2mgw-x8rm is a medium-severity (CVSS 4.8) Missing Authentication vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-5mx2-2mgw-x8rm.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
openclawnpmDescription
Summary
BlueBubbles webhook auth in the optional beta iMessage plugin allowed a passwordless fallback path. In some reverse-proxy/local routing setups, this could allow unauthenticated webhook events.
Affected Component and Scope
- Component:
extensions/bluebubbleswebhook handler - Scope: only deployments using the optional BlueBubbles plugin where webhook password auth was not configured for incoming webhook events
Affected Packages / Versions
- Package:
openclaw/openclaw(npm) - Latest published npm version at triage time (2026-02-21):
2026.2.19-2 - Affected structured range:
<=2026.2.19-2 - Fixed on
main; planned patched release:2026.2.21(>=2026.2.21)
Details
The vulnerable implementation had multiple auth branches, including a passwordless fallback with loopback/proxy heuristics.
The fix now uses one authentication codepath:
- inbound webhook token/guid must match
channels.bluebubbles.password - webhook target matching is consolidated to shared plugin-sdk logic
- BlueBubbles config validation now requires
passwordwhenserverUrlis set
Impact
BlueBubbles is an optional beta iMessage plugin, and onboarding/channel-add flows already require a password. Practical exposure is mainly custom/manual configurations that omitted webhook password authentication.
Remediation
- Upgrade to a release that includes this patch (
>=2026.2.21, planned). - Ensure BlueBubbles webhook delivery includes a matching password (
?password=<password>orx-password).
Fix Commit(s)
6b2f2811dc623e5faaf2f76afaa9279637174590283029bdea23164ab7482b320cb420d1b90df806
Release Process Note
patched_versions is pre-set to the planned next release (2026.2.21) so once npm release is out, advisory publish can proceed without additional ticket edits.
OpenClaw thanks @zpbrent for reporting.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | openclaw | all versions | 2026.2.21npm install openclaw@2026.2.21 |
Affected Products
openclawopenclawDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update openclaw to 2026.2.21 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5mx2-2mgw-x8rm is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-5mx2-2mgw-x8rm in your dependencies?
Find it across npm, including transitive dependencies.