Action Commands (run/shell/exec) Against Library URIs Ignore Configured Remote EndpointGHSA-5mv9-q7fq-9394
MEDIUMFix: sylabs/singularity@d52ae9dGHSA-5mv9-q7fq-9394 is a medium-severity (CVSS 6.3) Improper Input Validation vulnerability in github.com/sylabs/singularity. A fix is available for github.com/sylabs/singularity — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/sylabs/singularityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Due to incorrect use of a default URL, singularity action commands (run/shell/exec) specifying a container using a library:// URI will always attempt to retrieve the container from the default remote endpoint (cloud.sylabs.io) rather than the configured remote endpoint.
An attacker may be able to push a malicious container to the default remote endpoint with a URI that is identical to the URI used by a victim with a non-default remote endpoint, thus executing the malicious container.
Only action commands (run/shell/exec) against library:// URIs are affected. Other commands such as pull / push respect the configured remote endpoint.
Patches
All users should upgrade to Singularity 3.7.4 or later.
A patch was applied at: https://github.com/sylabs/singularity/commit/d52ae9d13979733c5e987a566fae59ed6f1bf796
Workarounds
Users who only interact with the default remote endpoint are not affected.
Installations with an execution control list configured to restrict execution to containers signed with specific secure keys are not affected.
For more information
General questions about the impact of the advisory can be asked in the:
Any sensitive security concerns should be directed to: [email protected]
See our Security Policy here: https://sylabs.io/security-policy
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/sylabs/singularity | ≥ 3.7.2&&< 3.7.4 | 3.7.4go get github.com/sylabs/singularity@v3.7.4 |
Affected Products
singularitysylabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/sylabs/singularity, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/sylabs/singularity to 3.7.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5mv9-q7fq-9394 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-5mv9-q7fq-9394 in your dependencies?
Find it across Go, including transitive dependencies.