Magento remote code execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilitiesGHSA-5gmh-85x8-5cx7
GHSA-5gmh-85x8-5cx7 is a remote code execution vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Real-World Exposure
magento/community-edition🐘magento/community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Magento Commerce and Open Source 2.2.5 and 2.1.14 contain multiple security enhancements that help close authenticated Admin user remote code execution (RCE), Cross-Site Scripting (XSS) and other vulnerabilities.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.1&&< 2.1.14 | 2.1.14composer require magento/community-edition:^2.1.14 |
| 🐘Packagist | magento/community-edition | ≥ 2.2&&< 2.2.5 | 2.2.5composer require magento/community-edition:^2.2.5 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.1.14 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5gmh-85x8-5cx7 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-5gmh-85x8-5cx7 in your dependencies?
Find it across Packagist, including transitive dependencies.