NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💧
💧 Hex📦 npm
Not in CISA KEV
MEDIUM severity

phoenix_html allows Cross-site Scripting in HEEx class attributesGHSA-5g2h-9x5v-5h3x

MEDIUMFix: phoenixframework/phoenix_html@62a0139

GHSA-5g2h-9x5v-5h3x is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in phoenix_html. A fix is available for phoenix_html — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-5g2h-9x5v-5h3x.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs38th percentile — riskier than 38% of all scored CVEsHighest risk
0.00%0.31%0.62%0.93%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💧phoenix_html📦phoenix_html

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Hex, npm packages — download data is not available via public APIs for these ecosystems.

Description

tag.ex in Phoenix Phoenix.HTML (aka phoenix_html) before 3.0.4 allows XSS in HEEx class attributes.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💧Hexphoenix_htmlall versions3.0.4mix deps.update phoenix_html
📦npmphoenix_htmlall versions3.0.4npm install phoenix_html@3.0.4

Affected Products

1 product · 1 configurations
Application
phoenix htmlphoenixframework
< 3.0.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for phoenix_html, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update phoenix_html to 3.0.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5g2h-9x5v-5h3x is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

tag.ex in Phoenix Phoenix.HTML (aka phoenix_html) before 3.0.4 allows XSS in HEEx class attributes
O3 Security · Impact-Aware SCA

Is GHSA-5g2h-9x5v-5h3x in your dependencies?

Find it across Hex, npm, including transitive dependencies.

phoenix_html allows Cross-site Scripting in HEEx class…