NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

irisnet-crypto RCE VulnerabilityGHSA-5fh8-x9xc-hxmc

CRITICALFix: dreamer-zq/irisnet-crypto@7ea0e65

GHSA-5fh8-x9xc-hxmc is a critical-severity (CVSS 9.8) Code Injection vulnerability in irisnet-crypto. A fix is available for irisnet-crypto — see the affected versions and patch details below.

Also known asCVE-2019-9115
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 22, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.61%1.35%2.09%2.83%1.1%2.3%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

0other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
irisnet-cryptonpm
8downloads / week

Description

In irisnet-crypto before 1.1.7 for IRISnet, the util/utils.js file allows code execution because of unsafe eval usage.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmirisnet-cryptoall versions1.1.7npm install irisnet-crypto@1.1.7

Affected Products

1 product · 1 configurations
Application
irisnet-cryptoirisnet
< 1.1.7
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for irisnet-crypto, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update irisnet-crypto to 1.1.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5fh8-x9xc-hxmc is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

In irisnet-crypto before 1.1.7 for IRISnet, the util/utils.js file allows code execution because of unsafe eval usage.
O3 Security · Impact-Aware SCA

Is GHSA-5fh8-x9xc-hxmc in your dependencies?

Find it across npm, including transitive dependencies.

irisnet-crypto RCE Vulnerability (Critical 9.8)