Symfony Vulnerable to PHP Eval InjectionGHSA-5c58-w9xc-qcj9
Fix: symfony/symfony#14167GHSA-5c58-w9xc-qcj9 is a Code Injection vulnerability in symfony/symfony. A fix is available for symfony/symfony — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
symfony/symfony🐘symfony/symfony🐘symfony/symfony🐘symfony/http-kernel🐘symfony/http-kernel🐘symfony/http-kernelReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Applications with ESI support (and SSI support as of Symfony 2.6) enabled and using the Symfony built-in reverse proxy (the `Symfony\Component\HttpKernel\HttpCache class) are vulnerable to PHP code injection; a malicious user can inject PHP code that will be executed by the server.
HttpCache uses eval() to execute files in its cache when they contain ESI tags (and only when ESI is enabled). The vulnerability comes from the fact that PHP allows contents of <script language="php"> tags to be executed (and this kind of PHP tags is always available regardless of the configuration), but there were not escaped before the evaluation.
A possible exploit comes from websites also vulnerable to Cross-Site Scripting as an attacker can successfully conduct a PHP code injection attack by passing such a tag in a user submitted variable (for which proper output escaping was not applied).
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | symfony/symfony | ≥ 2.0.0&&< 2.3.27 | 2.3.27composer require symfony/symfony:^2.3.27 |
| 🐘Packagist | symfony/symfony | ≥ 2.4.0&&< 2.5.11 | 2.5.11composer require symfony/symfony:^2.5.11 |
| 🐘Packagist | symfony/symfony | ≥ 2.6.0&&< 2.6.6 | 2.6.6composer require symfony/symfony:^2.6.6 |
| 🐘Packagist | symfony/http-kernel | ≥ 2.0.0&&< 2.3.27 | 2.3.27composer require symfony/http-kernel:^2.3.27 |
| 🐘Packagist | symfony/http-kernel | ≥ 2.4.0&&< 2.5.11 | 2.5.11composer require symfony/http-kernel:^2.5.11 |
| 🐘Packagist | symfony/http-kernel | ≥ 2.6.0&&< 2.6.6 | 2.6.6composer require symfony/http-kernel:^2.6.6 |
Affected Products
symfonysensiolabsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for symfony/symfony, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update symfony/symfony to 2.3.27 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5c58-w9xc-qcj9 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is GHSA-5c58-w9xc-qcj9 in your dependencies?
Find it across Packagist, including transitive dependencies.