NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

MLflow Server-Side Request Forgery (SSRF)GHSA-59v3-898r-qwhj

CRITICALFix: mlflow/mlflow@8174250

GHSA-59v3-898r-qwhj is a critical-severity (CVSS 9.8) Server-Side Request Forgery (SSRF) vulnerability in mlflow. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for mlflow — see the affected versions and patch details below.

Also known asBIT-mlflow-2023-6974CVE-2023-6974PYSEC-2026-416
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 8, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
1.01%1.70%2.40%3.09%2.6%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍mlflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

A malicious user could use this issue to access internal HTTP(s) servers and in the worst case (ie: aws instance) it could be abused to get a remote code execution on the victim machine.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImlflowall versions2.9.2pip install --upgrade 'mlflow==2.9.2'

Affected Products

1 product · 1 configurations
Application
mlflowlfprojects
< 2.9.2
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for mlflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update mlflow to 2.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-59v3-898r-qwhj is resolved across your whole dependency graph.

  3. Workarounds

    Restrict outbound requests from the affected component to an allowlist of hosts, block access to link-local and internal address ranges at the network layer, and require authentication on internal services so a forged request cannot reach them unauthenticated.

Frequently Asked Questions

A malicious user could use this issue to access internal HTTP(s) servers and in the worst case (ie: aws instance) it could be abused to get a remote code execution on the victim machine.
O3 Security · Impact-Aware SCA

Is GHSA-59v3-898r-qwhj in your dependencies?

Find it across PyPI, including transitive dependencies.

MLflow Server-Side Request Forgery (SSRF) (Critical 9.8)