NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
MEDIUM severity

Reverse Tabnabbing in quillGHSA-588m-9qg5-35pq

MEDIUMFix: quilljs/quill#2674

GHSA-588m-9qg5-35pq is a medium-severity (CVSS 6.5) vulnerability in quill. A fix is available for quill — see the affected versions and patch details below.

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Sep 28, 2021 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

2Kother npm packages depend on this — each one inherits the vulnerability until it's patched upstream
quillnpm
8.7Mdownloads / week

Description

Versions of quill prior to 1.3.7 are vulnerable to Reverse Tabnabbing. The package uses target='_blank' in anchor tags, allowing attackers to access window.opener for the original page when opening links. This is commonly used for phishing attacks.

Recommendation

No fix is currently available. Consider using an alternative package until a fix is made available.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmquillall versions1.3.7npm install quill@1.3.7

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for quill, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update quill to 1.3.7 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-588m-9qg5-35pq is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Versions of `quill` prior to 1.3.7 are vulnerable to [Reverse Tabnabbing](https://www.owasp.org/index.php/Reverse_Tabnabbing). The package uses `target='_blank'` in anchor tags, allowing attackers to access `window.opener` for the original page when opening links. This is commonly used for phishing attacks. ## Recommendation No fix is currently available. Consider using an alternative package until a fix is made available.
O3 Security · Impact-Aware SCA

Is GHSA-588m-9qg5-35pq in your dependencies?

Find it across npm, including transitive dependencies.

Reverse Tabnabbing in quill (Medium 6.5)