NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦 npm
Not in CISA KEV

OpenClaw unpaired device identity can bypass operator pairing and self-assign operator scopes with shared authGHSA-553v-f69r-656j

Fix: openclaw/openclaw@8d1481c

GHSA-553v-f69r-656j is a CWE-863 vulnerability in openclaw. A fix is available for openclaw — see the affected versions and patch details below.

Also known asCVE-2026-32042
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-553v-f69r-656j.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs39th percentile — riskier than 39% of all scored CVEsHighest risk
0.00%0.38%0.77%1.15%0.1%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

133other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
openclawnpm
2.4Mdownloads / week

Description

Summary

A client using shared gateway auth could attach an unpaired device identity and request elevated operator scopes (including operator.admin) before pairing approval, enabling privilege escalation.

Impact

Attackers with valid shared gateway auth could self-assign higher operator scopes by presenting a self-signed, unpaired device identity.

Affected Packages / Versions

  • Package: openclaw (npm)
  • Affected: >= 2026.2.22 <= 2026.2.24
  • Latest published npm at triage time: 2026.2.24
  • Planned patched release: 2026.2.25

Remediation

Require pairing for operator device-identity sessions authenticated with shared token/password auth (except existing control-ui trusted-proxy/control-ui bypass policy paths).

Fix Commit(s)

  • 8d1481cb4a9d31bd617e52dc8c392c35689d9dea

Release Process Note

patched_versions is pre-set to the release (>= 2026.2.25). Advisory published with npm release 2026.2.25.

OpenClaw thanks @tdjackey for reporting.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmopenclaw≥ 2026.2.22&&< 2026.2.252026.2.25npm install openclaw@2026.2.25

Affected Products

1 product · 1 configurations
Application
openclawopenclaw
≥ 2026.2.22 && < 2026.2.25
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for openclaw, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update openclaw to 2026.2.25 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-553v-f69r-656j is resolved across your whole dependency graph.

  3. Workarounds

    Close the privilege gap rather than the entry point: audit which accounts, roles and service identities can reach the affected operation, drop the component to the least privilege it actually needs, and review file and directory permissions created by earlier installs — a default left in place is what makes this reachable.

Frequently Asked Questions

### Summary A client using shared gateway auth could attach an unpaired device identity and request elevated operator scopes (including `operator.admin`) before pairing approval, enabling privilege escalation. ### Impact Attackers with valid shared gateway auth could self-assign higher operator scopes by presenting a self-signed, unpaired device identity. ### Affected Packages / Versions - Package: `openclaw` (npm) - Affected: `>= 2026.2.22 <= 2026.2.24` - Latest published npm at triage time: `2026.2.24` - Planned patched release: `2026.2.25` ### Remediation Require pairing for operator dev
O3 Security · Impact-Aware SCA

Is GHSA-553v-f69r-656j in your dependencies?

Find it across npm, including transitive dependencies.

OpenClaw unpaired device identity can bypass operator…