NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

Code injection via SVG file in convert-svg-coreGHSA-54px-mhwv-5v8x

HIGHFix: neocotic/convert-svg@a43dffa

GHSA-54px-mhwv-5v8x is a high-severity (CVSS 8.6) Code Injection vulnerability in convert-svg-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for convert-svg-core — see the affected versions and patch details below.

Also known asCVE-2022-24429SNYK-JS-CONVERTSVGCORE-2859212
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs60th percentile — riskier than 60% of all scored CVEsHighest risk
0.00%0.47%0.94%1.41%0.3%0.9%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

5other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
convert-svg-corenpm
18Kdownloads / week

Description

The package convert-svg-core before 0.6.3 are vulnerable to Arbitrary Code Injection when using a specially crafted SVG file. An attacker can read arbitrary files from the file system and then show the file content as a converted PNG file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmconvert-svg-coreall versions0.6.3npm install convert-svg-core@0.6.3

Affected Products

1 product · 1 configurations
Application
convert-svg-coreconvert-svg-core_project
< 0.6.3
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for convert-svg-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update convert-svg-core to 0.6.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-54px-mhwv-5v8x is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The package convert-svg-core before 0.6.3 are vulnerable to Arbitrary Code Injection when using a specially crafted SVG file. An attacker can read arbitrary files from the file system and then show the file content as a converted PNG file.
O3 Security · Impact-Aware SCA

Is GHSA-54px-mhwv-5v8x in your dependencies?

Find it across npm, including transitive dependencies.

Code injection via SVG file in convert-svg-core (High 8.6)