Compromised version of intercom-client published to npmGHSA-54pg-9963-v8vg
CRITICALGHSA-54pg-9963-v8vg is a critical-severity (CVSS 9.3) vulnerability in intercom-client. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
intercom-clientnpmDescription
Impact
On April 30, 2026, version 7.0.4 of intercom-client was published to npm using credentials obtained from a compromised developer account. This version was not produced by Intercom's build pipeline.
The malicious version contained an obfuscated JavaScript payload that executed during package installation via a preinstall hook. The payload harvested credentials from the environment in which it ran, including cloud provider credentials (AWS, GCP, Azure), environment variables, .env files, GitHub and npm tokens, SSH keys, local configuration files, and cloud metadata service credentials.
Harvested data was exfiltrated to attacker-controlled GitHub repositories. The package was live on npm for approximately 2 hours (15:00-17:00 UTC).
This compromise is part of the "Mini Shai-Hulud" supply chain campaign tracked by Wiz and Socket.
Developers can check if their projects are affected by running: npm list intercom-client. If it shows 7.0.4, the project is affected.
Patches
Version 7.0.3 and all prior versions are unaffected. Downgrade to 7.0.3 immediately.
Workarounds
If a developer installed version 7.0.4 on any machine or CI system, treat all credentials accessible from that environment as compromised and rotate them. Check lock files (package-lock.json, yarn.lock, pnpm-lock.yaml) for references to 7.0.4. Review CI/CD build logs for any npm install that resolved to 7.0.4 between 15:00 and 17:00 UTC on April 30, 2026.
Resources
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | intercom-client | all versions | No fix |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for intercom-client, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Remediation status
The records we use list no patched version of intercom-client for GHSA-54pg-9963-v8vg. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.
Mitigate without a patch
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-54pg-9963-v8vg in your dependencies?
Find it across npm, including transitive dependencies.