Magento Improper Access Control vulnerabilityGHSA-539v-w87w-w62c
MEDIUMGHSA-539v-w87w-w62c is a medium-severity (CVSS 6.5) CWE-284 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-539v-w87w-w62c.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition🐘magento/community-edition+2 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Improper Access Control vulnerability that could result in a Security feature bypass. A low-privileged attacker could leverage this vulnerability to bypass security measures and gain unauthorized read access. Exploitation of this issue does not require user interaction.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.4.7-beta1&&< 2.4.7-p4 | 2.4.7-p4composer require magento/community-edition:^2.4.7-p4 |
| 🐘Packagist | magento/community-edition | ≥ 2.4.6-p1&&< 2.4.6-p9 | 2.4.6-p9composer require magento/community-edition:^2.4.6-p9 |
| 🐘Packagist | magento/community-edition | ≥ 2.4.5-p1&&< 2.4.5-p11 | 2.4.5-p11composer require magento/community-edition:^2.4.5-p11 |
| 🐘Packagist | magento/community-edition | all versions | 2.4.4-p12composer require magento/community-edition:^2.4.4-p12 |
| 🐘Packagist | magento/community-edition | all versions | No fix |
| 🐘Packagist | magento/community-edition | all versions | No fix |
Affected Products
commerce b2badobeDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.4.7-p4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-539v-w87w-w62c is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-539v-w87w-w62c in your dependencies?
Find it across Packagist, including transitive dependencies.