n8n Vulnerable to XSS via MCP OAuth clientGHSA-537j-gqpc-p7fq
HIGHGHSA-537j-gqpc-p7fq is a high-severity (CVSS 8.2) Cross-site Scripting (XSS) vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-537j-gqpc-p7fq.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
n8nnpmDescription
Impact
An unauthenticated attacker could register a malicious MCP OAuth client with a crafted client_name. If a victim user authorized the OAuth consent dialog and a second user subsequently revoked that access, a toast notification would render the injected script. Clicking the link would execute arbitrary JavaScript in the victim's authenticated n8n browser session, enabling credential and session token theft, workflow manipulation, or privilege escalation.
Patches
This issue has been fixed in n8n version 2.14.2. Users should upgrade to this version or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Restrict access to the n8n instance and the MCP OAuth registration endpoint to trusted users only.
- Disable MCP server functionality if it is not actively required.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | n8n | all versions | 1.123.32npm install n8n@1.123.32 |
| 📦npm | n8n | ≥ 2.18.0&&< 2.18.1 | 2.18.1npm install n8n@2.18.1 |
| 📦npm | n8n | ≥ 2.17.0&&< 2.17.4 | 2.17.4npm install n8n@2.17.4 |
Affected Products
n8nn8nDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update n8n to 1.123.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-537j-gqpc-p7fq is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-537j-gqpc-p7fq in your dependencies?
Find it across npm, including transitive dependencies.