NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

Apache Airflow: XSS vulnerability in Task Instance Log/Log DetailsGHSA-52gm-qmg3-r4qp

MEDIUMFix: apache/airflow#38882

GHSA-52gm-qmg3-r4qp is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in apache-airflow. A fix is available for apache-airflow — see the affected versions and patch details below.

Also known asBIT-airflow-2024-32077CVE-2024-32077PYSEC-2024-264
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-52gm-qmg3-r4qp.

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk-0.01%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
1.01%1.99%2.97%3.95%3.4%1.6%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍apache-airflow

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIapache-airflow≥ 2.9.0&&< 2.9.12.9.1pip install --upgrade 'apache-airflow==2.9.1'

Affected Products

1 product · 6 configurations
Application
airflowapache
1 version
2.9.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for apache-airflow, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update apache-airflow to 2.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-52gm-qmg3-r4qp is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Apache Airflow version 2.9.0 has a vulnerability that allows an authenticated attacker to inject malicious data into the task instance logs.  Users are recommended to upgrade to version 2.9.1, which fixes this issue.
O3 Security · Impact-Aware SCA

Is GHSA-52gm-qmg3-r4qp in your dependencies?

Find it across PyPI, including transitive dependencies.

Apache Airflow: XSS vulnerability in Task Instance…