Shopware Improper Session Handling in store-api account logoutGHSA-5297-wrrp-rcj7
MEDIUMFix: shopware/shopware@5cc84ddGHSA-5297-wrrp-rcj7 is a medium-severity (CVSS 5.3) CWE-613 vulnerability in shopware/core. A fix is available for shopware/core — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-5297-wrrp-rcj7.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
shopware/core🐘shopware/platform🐘shopware/core🐘shopware/platformReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Shopware 6 is an open commerce platform based on Symfony Framework and Vue. Starting in version 6.3.5.0 and prior to versions 6.6.1.0 and 6.5.8.8, when a authenticated request is made to POST /store-api/account/logout, the cart will be cleared, but the User won't be logged out. This affects only the direct store-api usage, as the PHP Storefront listens additionally on CustomerLogoutEvent and invalidates the session additionally. The problem has been fixed in Shopware 6.6.1.0 and 6.5.8.8. Those who are unable to update can install the latest version of the Shopware Security Plugin as a workaround.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | shopware/core | ≥ 6.3.5.0&&< 6.5.8.8 | 6.5.8.8composer require shopware/core:^6.5.8.8 |
| 🐘Packagist | shopware/platform | ≥ 6.3.5.0&&< 6.5.8.8 | 6.5.8.8composer require shopware/platform:^6.5.8.8 |
| 🐘Packagist | shopware/core | ≥ 6.6.0.0-rc1&&< 6.6.1.0 | 6.6.1.0composer require shopware/core:^6.6.1.0 |
| 🐘Packagist | shopware/platform | ≥ 6.6.0.0-rc1&&< 6.6.1.0 | 6.6.1.0composer require shopware/platform:^6.6.1.0 |
Affected Products
shopwareshopwareDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for shopware/core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update shopware/core to 6.5.8.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-5297-wrrp-rcj7 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is GHSA-5297-wrrp-rcj7 in your dependencies?
Find it across Packagist, including transitive dependencies.