NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

Moodle allows reflected XSS via question bank filterGHSA-4w32-c9g7-27qx

HIGH

GHSA-4w32-c9g7-27qx is a high-severity (CVSS 8.3) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Also known asBIT-moodle-2025-26530CVE-2025-26530
Published
Updated
Affected
3 pkgs
Patched
3 / 3
Exploits
None indexed
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for GHSA-4w32-c9g7-27qx.

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk+0.00%
Lower risk than most CVEs30th percentile — riskier than 30% of all scored CVEsHighest risk
0.00%0.49%0.97%1.46%1.0%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

The question bank filter required additional sanitizing to prevent a reflected XSS risk.

Affected Packages

3 total 3 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 4.5.0-beta&&< 4.5.24.5.2composer require moodle/moodle:^4.5.2
🐘Packagistmoodle/moodle≥ 4.4.0-beta&&< 4.4.64.4.6composer require moodle/moodle:^4.4.6
🐘Packagistmoodle/moodle≥ 4.3.0-beta&&< 4.3.104.3.10composer require moodle/moodle:^4.3.10

Affected Products

1 product · 3 configurations
Application
moodlemoodle
≥ 4.5.0 && < 4.5.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 4.5.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4w32-c9g7-27qx is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

The question bank filter required additional sanitizing to prevent a reflected XSS risk.
O3 Security · Impact-Aware SCA

Is GHSA-4w32-c9g7-27qx in your dependencies?

Find it across Packagist, including transitive dependencies.

Moodle allows reflected XSS via question bank filter