eyre: Parts of Report are dropped as the wrong type during downcastGHSA-4v52-7q2x-v4xj
HIGHFix: eyre-rs/eyre@770ac3fGHSA-4v52-7q2x-v4xj is a high-severity (CVSS 7.5) remote code execution vulnerability in eyre. A fix is available for eyre — see the affected versions and patch details below.
Real-World Exposure
eyreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
In affected versions, after a Report is constructed using wrap_err or wrap_err_with to attach a message of type D onto an error of type E, then using downcast to recover ownership of either the value of type D or the value of type E, one of two things can go wrong:
-
If downcasting to
E, there remains a value of typeDto be dropped. It is incorrectly "dropped" by runningE's drop behavior, rather thanD's. For example ifDis&strandEisstd::io::Error, there would be a call ofstd::io::Error::dropin which the reference received by theDropimpl does not refer to a valid value of typestd::io::Error, but instead to&str. -
If downcasting to
D, there remains a value of typeEto be dropped. WhenDandEdo not happen to be the same size,E's drop behavior is incorrectly executed in the wrong location. The reference received by theDropimpl may point left or right of the realEvalue that is meant to be getting dropped.
In both cases, when the Report contains an error E that has nontrivial drop behavior, the most likely outcome is memory corruption.
When the Report contains an error E that has trivial drop behavior (for example a Utf8Error) but where D has nontrivial drop behavior (such as String), the most likely outcome is that downcasting to E would leak D.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | eyre | ≥ 0.6.9&&< 0.6.12 | 0.6.12cargo update -p eyre --precise 0.6.12 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for eyre, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update eyre to 0.6.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4v52-7q2x-v4xj is resolved across your whole dependency graph.
Workarounds
Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.
Frequently Asked Questions
Is GHSA-4v52-7q2x-v4xj in your dependencies?
Find it across crates.io, including transitive dependencies.