Authentication Bypass Using an Alternate Path or Channel in Apache TomcatGHSA-4v3g-g84w-hv7r
CRITICALFix: apache/tomcat@648122fGHSA-4v3g-g84w-hv7r is a critical-severity (CVSS 9.1) vulnerability in org.apache.tomcat:tomcat-jasper. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for org.apache.tomcat:tomcat-jasper — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-4v3g-g84w-hv7r.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.tomcat:tomcat-jasper☕org.apache.tomcat:tomcat-jasper☕org.apache.tomcat:tomcat-jasper☕org.apache.tomcat:tomcat-jasper☕org.apache.tomcat:jasper☕org.apache.tomcat.embed:tomcat-embed-jasper☕org.apache.tomcat.embed:tomcat-embed-jasper☕org.apache.tomcat.embed:tomcat-embed-jasper+2 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In Apache Tomcat 9.0.0.M1 to 9.0.0.M9, 8.5.0 to 8.5.4, 8.0.0.RC1 to 8.0.36, 7.0.0 to 7.0.70 and 6.0.0 to 6.0.45 a malicious web application was able to bypass a configured SecurityManager via a Tomcat utility method that was accessible to web applications.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.tomcat:tomcat-jasper | ≥ 9.0.0.M1&&< 9.0.0.M10 | 9.0.0.M10org.apache.tomcat:tomcat-jasper:9.0.0.M10 |
| ☕Maven | org.apache.tomcat:tomcat-jasper | ≥ 8.5.0&&< 8.5.5 | 8.5.5org.apache.tomcat:tomcat-jasper:8.5.5 |
| ☕Maven | org.apache.tomcat:tomcat-jasper | ≥ 8.0.0RC1&&< 8.0.37 | 8.0.37org.apache.tomcat:tomcat-jasper:8.0.37 |
| ☕Maven | org.apache.tomcat:tomcat-jasper | ≥ 7.0.0&&< 7.0.72 | 7.0.72org.apache.tomcat:tomcat-jasper:7.0.72 |
| ☕Maven | org.apache.tomcat:jasper | ≥ 6.0.0&&< 6.0.47 | 6.0.47org.apache.tomcat:jasper:6.0.47 |
| ☕Maven | org.apache.tomcat.embed:tomcat-embed-jasper | ≥ 9.0.0.M1&&< 9.0.0.M10 | 9.0.0.M10org.apache.tomcat.embed:tomcat-embed-jasper:9.0.0.M10 |
Affected Products
tomcatapacheubuntu linuxcanonicaldebian linuxdebianoncommand insightnetapponcommand shiftnetappsnap creator frameworknetappResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.tomcat:tomcat-jasper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.tomcat:tomcat-jasper to 9.0.0.M10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4v3g-g84w-hv7r is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
| Product | Fixed in | Advisory |
|---|---|---|
| Red Hat Enterprise Linux 7 | tomcat-0:7.0.76-2.el7 | RHSA-2017:2247 |
| Red Hat JBoss Enterprise Application Platform 6.4 | see advisory | RHSA-2017:1551 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 5 | hornetq-0:2.3.25-21.SP19_redhat_1.1.ep6.el5 | RHSA-2017:1550 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | hornetq-0:2.3.25-21.SP19_redhat_1.1.ep6.el6 | RHSA-2017:1549 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 6 | jboss-ec2-eap-0:7.5.16-1.Final_redhat_1.ep6.el6 | RHSA-2017:1552 |
| Red Hat JBoss Enterprise Application Platform 6.4 for RHEL 7 | hornetq-0:2.3.25-21.SP19_redhat_1.1.ep6.el7 | RHSA-2017:1548 |
| Red Hat JBoss Web Server 3.1 | see advisory | RHSA-2017:0457 |
| Red Hat JBoss Web Server 3 for RHEL 6 | hibernate4-eap6-0:4.2.23-1.Final_redhat_1.1.ep6.el6 | RHSA-2017:0455 |
Frequently Asked Questions
Is GHSA-4v3g-g84w-hv7r in your dependencies?
Find it across Maven, including transitive dependencies.