Cross-Site Request Forgery (CSRF) in automad/automadGHSA-4j8w-p6hv-3qxc
MEDIUMGHSA-4j8w-p6hv-3qxc is a medium-severity (CVSS 4.3) Cross-Site Request Forgery (CSRF) vulnerability in automad/automad. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for automad/automad — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
automad/automadReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
A vulnerability was found in automad up to 1.10.9. It has been rated as problematic. This issue affects some unknown processing of the file /dashboard?controller=UserCollection::createUser of the component User Creation Handler. The manipulation leads to cross-site request forgery. The attack may be initiated remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-248687. NOTE: The vendor was contacted early about this disclosure but did not respond in any way.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | automad/automad | all versions | 2.0.0-alpha.1composer require automad/automad:^2.0.0-alpha.1 |
Affected Products
automadautomadResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for automad/automad, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update automad/automad to 2.0.0-alpha.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4j8w-p6hv-3qxc is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is GHSA-4j8w-p6hv-3qxc in your dependencies?
Find it across Packagist, including transitive dependencies.