Liferay Portal and Liferay DXP vulnerable to Cross-site ScriptingGHSA-4hxr-28mv-q729
MEDIUMGHSA-4hxr-28mv-q729 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in com.liferay.portal:release.portal.bom. A fix is available for com.liferay.portal:release.portal.bom — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-4hxr-28mv-q729.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.liferay.portal:release.portal.bom☕com.liferay.portal:release.dxp.bomReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Reflected cross-site scripting (XSS) vulnerability in Liferay Portal 7.1.0 through 7.4.3.38, and Liferay DXP 7.4 GA through update 38, 7.3 GA through update 36, 7.2 GA through fix pack 20 and 7.1 GA through fix pack 28 allows remote attackers to execute arbitrary web script or HTML via Dispatch name field
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.liferay.portal:release.portal.bom | ≥ 7.1.0&&< 7.4.3.39 | 7.4.3.39com.liferay.portal:release.portal.bom:7.4.3.39 |
| ☕Maven | com.liferay.portal:release.dxp.bom | ≥ 7.1&&< 7.4.13.u39 | 7.4.13.u39com.liferay.portal:release.dxp.bom:7.4.13.u39 |
Affected Products
digital experience platformliferayliferay portalliferayDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.liferay.portal:release.portal.bom, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.liferay.portal:release.portal.bom to 7.4.3.39 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4hxr-28mv-q729 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-4hxr-28mv-q729 in your dependencies?
Find it across Maven, including transitive dependencies.