NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

Cross-Site Request Forgery vulnerability in PrefectGHSA-4hh5-2678-83fx

HIGHFix: prefecthq/prefect@227dfcc

GHSA-4hh5-2678-83fx is a high-severity (CVSS 8.8) Cross-Site Request Forgery (CSRF) vulnerability in prefect. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for prefect — see the affected versions and patch details below.

Also known asCVE-2023-6022PYSEC-2026-1799
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs33th percentile — riskier than 33% of all scored CVEsHighest risk
0.00%0.30%0.59%0.89%0.2%0.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍prefect

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An attacker is able to steal secrets and potentially gain remote code execution via CSRF using a self-hosted, open source Prefect API.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIprefect≥ 2.0.0&&< 2.16.52.16.5pip install --upgrade 'prefect==2.16.5'

Affected Products

1 product · 1 configurations
Application
prefectprefect
all
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for prefect, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update prefect to 2.16.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4hh5-2678-83fx is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

An attacker is able to steal secrets and potentially gain remote code execution via CSRF using a self-hosted, open source Prefect API.
O3 Security · Impact-Aware SCA

Is GHSA-4hh5-2678-83fx in your dependencies?

Find it across PyPI, including transitive dependencies.

Cross-Site Request Forgery vulnerability in Prefect