Content-Security-Policy protection for user content disabled by Jenkins ZAP Pipeline PluginGHSA-4c87-9xq5-5c35
MEDIUMFix: jenkinsci/zap-pipeline-plugin@bca4b08GHSA-4c87-9xq5-5c35 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.vrondakis.zap:zap-pipeline. A fix is available for com.vrondakis.zap:zap-pipeline — see the affected versions and patch details below.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
com.vrondakis.zap:zap-pipelineReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins sets the Content-Security-Policy header to static files served by Jenkins (specifically DirectoryBrowserSupport), such as workspaces, /userContent, or archived artifacts.
ZAP Pipeline Plugin prior to 1.10 globally disables the Content-Security-Policy header for static files served by Jenkins. This allows cross-site scripting (XSS) attacks by users with the ability to control files in workspaces, archived artifacts, etc.
Jenkins instances with Resource Root URL configured are largely unaffected. A possible exception are file parameter downloads. The behavior of those depends on the specific version of Jenkins:
- Jenkins 2.231 and newer, including 2.235.x LTS, is unaffected, as all resource files from user content are generally served safely from a different domain, without restrictions from
Content-Security-Policyheader. - Jenkins between 2.228 (inclusive) and 2.230 (inclusive), as well as all releases of Jenkins 2.222.x LTS and the 2.204.6 LTS release, are affected by this vulnerability, as file parameters are not served via the Resource Root URL.
- Jenkins 2.227 and older, 2.204.5 and older, don’t have XSS protection for file parameter values, see SECURITY-1793.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.vrondakis.zap:zap-pipeline | all versions | 1.10com.vrondakis.zap:zap-pipeline:1.10 |
Affected Products
zap pipelinejenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.vrondakis.zap:zap-pipeline, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.vrondakis.zap:zap-pipeline to 1.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4c87-9xq5-5c35 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-4c87-9xq5-5c35 in your dependencies?
Find it across Maven, including transitive dependencies.