n8n Vulnerable to Unauthenticated Denial of Service via MCP Client RegistrationGHSA-49m9-pgww-9vq6
HIGHGHSA-49m9-pgww-9vq6 is a high-severity (CVSS 7.5) CWE-770 vulnerability in n8n. A fix is available for n8n — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-49m9-pgww-9vq6.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.
n8nnpmDescription
Impact
The MCP OAuth client registration endpoint accepted unauthenticated requests and stored client data without adequate resource controls. An unauthenticated remote attacker could exhaust server memory resources by sending large registration payloads, rendering the n8n instance unavailable. The MCP enable/disable toggle gates MCP access but did not restrict client registrations, meaning the endpoint is reachable regardless of whether MCP access is enabled on the instance.
The patches address the unbound registration with an upper bound of registered clients and disabling creation when MCP is disabled on the instance. Mean to restrict the payload size of requests already exist and can be used to control additional risks.
Patches
The issue has been fixed in n8n versions 1.123.32, 2.17.4, and 2.18.1. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Restrict network access to the n8n instance to prevent requests from untrusted sources.
- Reduce the maximum accepted payload size by lowering the
N8N_PAYLOAD_SIZE_MAXenvironment variable from its default value.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 📦npm | n8n | all versions | 1.123.32npm install n8n@1.123.32 |
| 📦npm | n8n | ≥ 2.18.0&&< 2.18.1 | 2.18.1npm install n8n@2.18.1 |
| 📦npm | n8n | ≥ 2.0.0&&< 2.17.4 | 2.17.4npm install n8n@2.17.4 |
Affected Products
n8nn8nDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for n8n, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update n8n to 1.123.32 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-49m9-pgww-9vq6 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Frequently Asked Questions
Is GHSA-49m9-pgww-9vq6 in your dependencies?
Find it across npm, including transitive dependencies.