Cross-Site Scripting (XSS) vulnerabilities in NeosGHSA-4542-p56h-8xww
GHSA-4542-p56h-8xww is a security vulnerability in typo3/neos. A fix is available for typo3/neos — see the affected versions and patch details below.
Real-World Exposure
typo3/neos🐘typo3/neosReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It has been discovered that Neos is vulnerable to several XSS attacks. Through these vulnerabilities, an attacker could tamper with page rendering, redirect victims to a fake login page, or capture user credentials (such as cookies). With the potential backdoor upload an attacker could gain access to the server itself, to an extent mainly limited by the server setup.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | typo3/neos | ≥ 1.2.0&&< 1.2.13 | 1.2.13composer require typo3/neos:^1.2.13 |
| 🐘Packagist | typo3/neos | ≥ 2.0.0&&< 2.0.4 | 2.0.4composer require typo3/neos:^2.0.4 |
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/neos, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update typo3/neos to 1.2.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4542-p56h-8xww is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is GHSA-4542-p56h-8xww in your dependencies?
Find it across Packagist, including transitive dependencies.