NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

TYPO3 Cross-Site Scripting in Form FrameworkGHSA-4459-qrcc-vfcf

MEDIUMFix: TYPO3-CMS/core@3b8b8b4

GHSA-4459-qrcc-vfcf is a medium-severity (CVSS 6.1) vulnerability in typo3/cms-core. A fix is available for typo3/cms-core — see the affected versions and patch details below.

Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Dec 5, 2024 · OSV.dev, FIRST.org (EPSS)

Real-World Exposure

2 pkgs affected
🐘typo3/cms-core🐘typo3/cms-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Failing to properly encode user input, frontend forms handled by the form framework (system extension “form”) are vulnerable to cross-site scripting.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagisttypo3/cms-core≥ 8.5.0&&< 8.7.238.7.23composer require typo3/cms-core:^8.7.23
🐘Packagisttypo3/cms-core≥ 9.0.0&&< 9.5.49.5.4composer require typo3/cms-core:^9.5.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for typo3/cms-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update typo3/cms-core to 8.7.23 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-4459-qrcc-vfcf is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Failing to properly encode user input, frontend forms handled by the form framework (system extension “form”) are vulnerable to cross-site scripting.
O3 Security · Impact-Aware SCA

Is GHSA-4459-qrcc-vfcf in your dependencies?

Find it across Packagist, including transitive dependencies.

TYPO3 Cross-Site Scripting in Form Framework