Apache ActiveMQ Artemis: Authenticated users could perform RCE via Jolokia MBeansGHSA-443j-grxv-2pgv
HIGHFix: apache/activemq-artemis@cfb585eGHSA-443j-grxv-2pgv is a high-severity (CVSS 8.8) CWE-285 vulnerability in org.apache.activemq:artemis-cli. EPSS puts its 30-day exploitation probability at 17.5% (97th percentile). A fix is available for org.apache.activemq:artemis-cli — see the affected versions and patch details below.
Exploitation Status
No confirmed exploitation observed yet
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for GHSA-443j-grxv-2pgv.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.apache.activemq:artemis-cliReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Apache ActiveMQ Artemis allows access to diagnostic information and controls through MBeans, which are also exposed through the authenticated Jolokia endpoint. Before version 2.29.0, this also included the Log4J2 MBean. This MBean is not meant for exposure to non-administrative users. This could eventually allow an authenticated attacker to write arbitrary files to the filesystem and indirectly achieve RCE.
Users are recommended to upgrade to version 2.29.0 or later, which fixes the issue.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.apache.activemq:artemis-cli | all versions | 2.29.0org.apache.activemq:artemis-cli:2.29.0 |
Affected Products
artemisapacheDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:artemis-cli, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.apache.activemq:artemis-cli to 2.29.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms GHSA-443j-grxv-2pgv is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
This vulnerability is considered Important rather than Critical because, while it does allow an authenticated attacker to exploit exposed MBeans (such as the Log4J2 MBean) to write arbitrary files, the exploit path requires prior authentication. The attacker must have valid credentials to access the Jolokia endpoint,…
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for GHSA-443j-grxv-2pgv (CC BY 4.0)
Frequently Asked Questions
Is GHSA-443j-grxv-2pgv in your dependencies?
Find it across Maven, including transitive dependencies.